aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cmakeprojectmanager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/cmakeprojectmanager/CMakeLists.txt')
-rw-r--r--src/plugins/cmakeprojectmanager/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/plugins/cmakeprojectmanager/CMakeLists.txt b/src/plugins/cmakeprojectmanager/CMakeLists.txt
index 683a2a407a..057b413945 100644
--- a/src/plugins/cmakeprojectmanager/CMakeLists.txt
+++ b/src/plugins/cmakeprojectmanager/CMakeLists.txt
@@ -2,6 +2,7 @@ add_qtc_plugin(CMakeProjectManager
PLUGIN_CLASS CMakeProjectPlugin
DEPENDS QmlJS
PLUGIN_DEPENDS Core CppEditor ProjectExplorer TextEditor QtSupport
+ INCLUDES 3dparty/cmake
SOURCES
builddirparameters.cpp builddirparameters.h
cmake_global.h
@@ -15,8 +16,6 @@ add_qtc_plugin(CMakeProjectManager
cmakeeditor.cpp cmakeeditor.h
cmakefilecompletionassist.cpp cmakefilecompletionassist.h
cmakeformatter.cpp cmakeformatter.h
- cmakeformatteroptionspage.cpp cmakeformatteroptionspage.h
- cmakeformattersettings.cpp cmakeformattersettings.h
cmakeindenter.cpp cmakeindenter.h
cmakeinstallstep.cpp cmakeinstallstep.h
cmakekitinformation.cpp cmakekitinformation.h
@@ -44,4 +43,7 @@ add_qtc_plugin(CMakeProjectManager
presetsparser.cpp presetsparser.h
presetsmacros.cpp presetsmacros.h
projecttreehelper.cpp projecttreehelper.h
+ 3rdparty/cmake/cmListFileCache.cxx
+ 3rdparty/cmake/cmListFileLexer.cxx
+ 3rdparty/cmake/cmListFileCache.h
)