aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
new file mode 100644
index 0000000000..a921291f04
--- /dev/null
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -0,0 +1,44 @@
+add_qtc_plugin(CppEditor
+ DEFINES CPPEDITOR_LIBRARY
+ PLUGIN_DEPENDS Core CppTools ProjectExplorer TextEditor
+ SOURCES
+ cppautocompleter.cpp cppautocompleter.h
+ cppcodemodelinspectordialog.cpp cppcodemodelinspectordialog.h cppcodemodelinspectordialog.ui
+ cppdocumentationcommenthelper.cpp cppdocumentationcommenthelper.h
+ cppeditor.cpp cppeditor.h
+ cppeditor.qrc
+ cppeditor_global.h
+ cppeditorconstants.h
+ cppeditordocument.cpp cppeditordocument.h
+ cppeditorenums.h
+ cppeditorplugin.cpp cppeditorplugin.h
+ cppeditorwidget.cpp cppeditorwidget.h
+ cppfunctiondecldeflink.cpp cppfunctiondecldeflink.h
+ cpphighlighter.cpp cpphighlighter.h
+ cppincludehierarchy.cpp cppincludehierarchy.h
+ cppinsertvirtualmethods.cpp cppinsertvirtualmethods.h
+ cpplocalrenaming.cpp cpplocalrenaming.h
+ cppminimizableinfobars.cpp cppminimizableinfobars.h
+ cppoutline.cpp cppoutline.h
+ cppparsecontext.cpp cppparsecontext.h
+ cpppreprocessordialog.cpp cpppreprocessordialog.h cpppreprocessordialog.ui
+ cppquickfix.cpp cppquickfix.h
+ cppquickfixassistant.cpp cppquickfixassistant.h
+ cppquickfixes.cpp cppquickfixes.h
+ cpptypehierarchy.cpp cpptypehierarchy.h
+ cppuseselectionsupdater.cpp cppuseselectionsupdater.h
+ resourcepreviewhoverhandler.cpp resourcepreviewhoverhandler.h
+ EXPLICIT_MOC cppeditor.h
+)
+
+if (WITH_TESTS)
+ target_sources(CppEditor PRIVATE
+ cppdoxygen_test.cpp cppdoxygen_test.h
+ cppeditortestcase.cpp cppeditortestcase.h
+ cppincludehierarchy_test.cpp
+ cppquickfix_test.cpp cppquickfix_test.h
+ cppuseselections_test.cpp
+ fileandtokenactions_test.cpp
+ followsymbol_switchmethoddecldef_test.cpp
+ )
+endif()