aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/glsleditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/glsleditor/CMakeLists.txt')
-rw-r--r--src/plugins/glsleditor/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/plugins/glsleditor/CMakeLists.txt b/src/plugins/glsleditor/CMakeLists.txt
new file mode 100644
index 0000000000..9d5dc56629
--- /dev/null
+++ b/src/plugins/glsleditor/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_qtc_plugin(GLSLEditor
+ DEPENDS GLSL
+ PLUGIN_DEPENDS Core CppTools TextEditor
+ SOURCES
+ glslautocompleter.cpp glslautocompleter.h
+ glslcompletionassist.cpp glslcompletionassist.h
+ glsleditor.cpp glsleditor.h
+ glsleditor.qrc
+ glsleditorconstants.h
+ glsleditorplugin.cpp glsleditorplugin.h
+ glslhighlighter.cpp glslhighlighter.h
+ glslindenter.cpp glslindenter.h
+)