aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/imageviewer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imageviewer/CMakeLists.txt')
-rw-r--r--src/plugins/imageviewer/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/imageviewer/CMakeLists.txt b/src/plugins/imageviewer/CMakeLists.txt
new file mode 100644
index 0000000000..6bf9c9693c
--- /dev/null
+++ b/src/plugins/imageviewer/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_qtc_plugin(ImageViewer
+ DEPENDS OptionalSvg
+ PLUGIN_DEPENDS Core
+ SOURCES
+ exportdialog.cpp exportdialog.h
+ imageview.cpp imageview.h
+ imageviewer.cpp imageviewer.h
+ imageviewerconstants.h
+ imageviewerfactory.cpp imageviewerfactory.h
+ imageviewerfile.cpp imageviewerfile.h
+ imageviewerplugin.cpp imageviewerplugin.h
+ imageviewertoolbar.ui
+ multiexportdialog.cpp multiexportdialog.h
+ EXPLICIT_MOC imageviewer.h
+)