aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/macros/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/macros/CMakeLists.txt')
-rw-r--r--src/plugins/macros/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/plugins/macros/CMakeLists.txt b/src/plugins/macros/CMakeLists.txt
new file mode 100644
index 0000000000..544b16c5dd
--- /dev/null
+++ b/src/plugins/macros/CMakeLists.txt
@@ -0,0 +1,19 @@
+add_qtc_plugin(Macros
+ PLUGIN_DEPENDS Core TextEditor
+ SOURCES
+ actionmacrohandler.cpp actionmacrohandler.h
+ findmacrohandler.cpp findmacrohandler.h
+ imacrohandler.cpp imacrohandler.h
+ macro.cpp macro.h
+ macroevent.cpp macroevent.h
+ macrolocatorfilter.cpp macrolocatorfilter.h
+ macromanager.cpp macromanager.h
+ macrooptionspage.cpp macrooptionspage.h
+ macrooptionswidget.cpp macrooptionswidget.h macrooptionswidget.ui
+ macros.qrc
+ macrosconstants.h
+ macrosplugin.cpp macrosplugin.h
+ macrotextfind.cpp macrotextfind.h
+ savedialog.cpp savedialog.h savedialog.ui
+ texteditormacrohandler.cpp texteditormacrohandler.h
+)