aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmlpreview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/qmlpreview/CMakeLists.txt')
-rw-r--r--src/plugins/qmlpreview/CMakeLists.txt18
1 files changed, 1 insertions, 17 deletions
diff --git a/src/plugins/qmlpreview/CMakeLists.txt b/src/plugins/qmlpreview/CMakeLists.txt
index 40114a7e47..4c1889143a 100644
--- a/src/plugins/qmlpreview/CMakeLists.txt
+++ b/src/plugins/qmlpreview/CMakeLists.txt
@@ -1,7 +1,7 @@
add_qtc_plugin(QmlPreview
CONDITION TARGET QmlProjectManager
PUBLIC_DEPENDS QmlDebug
- DEPENDS QmlJS
+ DEPENDS QmlJS Qt::QmlPrivate
PLUGIN_DEPENDS
Core ProjectExplorer QmlJSTools QtSupport
ResourceEditor QmlProjectManager
@@ -22,19 +22,3 @@ extend_qtc_plugin(QmlPreview
tests/qmlpreviewclient_test.cpp tests/qmlpreviewclient_test.h
tests/qmlpreviewplugin_test.cpp tests/qmlpreviewplugin_test.h
)
-
-if(TARGET Qt6::QmlPrivate)
- get_target_property(qmldebugprivate_include_directories
- Qt6::QmlPrivate
- INTERFACE_INCLUDE_DIRECTORIES
- )
- find_file(have_qml_debug_translation_protocol
- NAMES private/qqmldebugtranslationprotocol_p.h
- PATHS ${qmldebugprivate_include_directories}
- )
- extend_qtc_plugin(QmlPreview
- CONDITION have_qml_debug_translation_protocol
- PUBLIC_DEPENDS Qt::QmlPrivate
- PUBLIC_DEFINES "FOUND_QML_DEBUG_TRANSLATION_PROTOCOL"
- )
-endif()