aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmlprojectmanager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/qmlprojectmanager/CMakeLists.txt')
-rw-r--r--src/plugins/qmlprojectmanager/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/plugins/qmlprojectmanager/CMakeLists.txt b/src/plugins/qmlprojectmanager/CMakeLists.txt
new file mode 100644
index 0000000000..ddef6f61f2
--- /dev/null
+++ b/src/plugins/qmlprojectmanager/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_qtc_plugin(QmlProjectManager
+ DEPENDS qmljs
+ PLUGIN_DEPENDS Core ProjectExplorer QtSupport
+ SOURCES
+ fileformat/filefilteritems.cpp fileformat/filefilteritems.h
+ fileformat/qmlprojectfileformat.cpp fileformat/qmlprojectfileformat.h
+ fileformat/qmlprojectitem.cpp fileformat/qmlprojectitem.h
+ qmlproject.cpp qmlproject.h
+ qmlproject.qrc
+ qmlprojectconstants.h
+ qmlprojectmanager_global.h
+ qmlprojectmanagerconstants.h
+ qmlprojectnodes.cpp qmlprojectnodes.h
+ qmlprojectplugin.cpp qmlprojectplugin.h
+ qmlprojectrunconfiguration.cpp qmlprojectrunconfiguration.h
+)