aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/vcsbase/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/vcsbase/CMakeLists.txt')
-rw-r--r--src/plugins/vcsbase/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/plugins/vcsbase/CMakeLists.txt b/src/plugins/vcsbase/CMakeLists.txt
new file mode 100644
index 0000000000..aa1b511d26
--- /dev/null
+++ b/src/plugins/vcsbase/CMakeLists.txt
@@ -0,0 +1,38 @@
+add_qtc_plugin(VcsBase
+ PLUGIN_DEPENDS Core CppTools DiffEditor ProjectExplorer TextEditor
+ PLUGIN_RECOMMENDS CodePaster
+ SOURCES
+ baseannotationhighlighter.cpp baseannotationhighlighter.h
+ basevcseditorfactory.cpp basevcseditorfactory.h
+ basevcssubmiteditorfactory.cpp basevcssubmiteditorfactory.h
+ cleandialog.cpp cleandialog.h cleandialog.ui
+ commonsettingspage.cpp commonsettingspage.h commonsettingspage.ui
+ commonvcssettings.cpp commonvcssettings.h
+ diffandloghighlighter.cpp diffandloghighlighter.h
+ nicknamedialog.cpp nicknamedialog.h nicknamedialog.ui
+ submiteditorfile.cpp submiteditorfile.h
+ submiteditorwidget.cpp submiteditorwidget.h submiteditorwidget.ui
+ submitfieldwidget.cpp submitfieldwidget.h
+ submitfilemodel.cpp submitfilemodel.h
+ vcsbase.qrc
+ vcsbase_global.h
+ vcsbaseclient.cpp vcsbaseclient.h
+ vcsbaseclientsettings.cpp vcsbaseclientsettings.h
+ vcsbaseconstants.h
+ vcsbasediffeditorcontroller.cpp vcsbasediffeditorcontroller.h
+ vcsbaseeditor.cpp vcsbaseeditor.h
+ vcsbaseeditorconfig.cpp vcsbaseeditorconfig.h
+ vcsbaseoptionspage.cpp vcsbaseoptionspage.h
+ vcsbaseplugin.cpp vcsbaseplugin.h
+ vcsbasesubmiteditor.cpp vcsbasesubmiteditor.h
+ vcscommand.cpp vcscommand.h
+ vcsoutputwindow.cpp vcsoutputwindow.h
+ vcsplugin.cpp vcsplugin.h
+ wizard/vcscommandpage.cpp wizard/vcscommandpage.h
+ wizard/vcsconfigurationpage.cpp wizard/vcsconfigurationpage.h
+ wizard/vcsjsextension.cpp wizard/vcsjsextension.h
+)
+
+if (WITH_TESTS)
+ target_compile_definitions(VcsBase PRIVATE SRC_DIR="${IDE_SOURCE_TREE}")
+endif()