aboutsummaryrefslogtreecommitdiffstats
path: root/src/tools/clangrefactoringbackend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/clangrefactoringbackend/CMakeLists.txt')
-rw-r--r--src/tools/clangrefactoringbackend/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/tools/clangrefactoringbackend/CMakeLists.txt b/src/tools/clangrefactoringbackend/CMakeLists.txt
new file mode 100644
index 0000000000..184ff60aeb
--- /dev/null
+++ b/src/tools/clangrefactoringbackend/CMakeLists.txt
@@ -0,0 +1,18 @@
+add_qtc_executable(clangrefactoringbackend
+ DEPENDS clangbackendipc
+ INCLUDES source
+ SOURCES
+ clangrefactoringbackendmain.cpp
+ source/clangquery.cpp source/clangquery.h
+ source/clangrefactoringbackend_global.h
+ source/clangtool.cpp source/clangtool.h
+ source/findcursorusr.h
+ source/findlocationsofusrs.h
+ source/findusrforcursoraction.cpp source/findusrforcursoraction.h
+ source/macropreprocessorcallbacks.cpp source/macropreprocessorcallbacks.h
+ source/refactoringcompilationdatabase.cpp source/refactoringcompilationdatabase.h
+ source/refactoringserver.cpp source/refactoringserver.h
+ source/sourcelocationsutils.h
+ source/symbolfinder.cpp source/symbolfinder.h
+ source/symbollocationfinderaction.cpp source/symbollocationfinderaction.h
+)