aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmldesigner/coretests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmldesigner/coretests/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmldesigner/coretests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/qml/qmldesigner/coretests/CMakeLists.txt b/tests/auto/qml/qmldesigner/coretests/CMakeLists.txt
new file mode 100644
index 0000000000..3e83f280af
--- /dev/null
+++ b/tests/auto/qml/qmldesigner/coretests/CMakeLists.txt
@@ -0,0 +1,20 @@
+# TODO: fix compiler errors
+return()
+
+add_qtc_test(tst_qml_testcore
+ DEPENDS qmljs Utils QmlEditorWidgets CPlusPlus Core QmlJSEditor
+ INCLUDES
+ "${CMAKE_SOURCE_DIR}/src/plugins/qmldesigner/designercore/include"
+ "${CMAKE_SOURCE_DIR}/src/plugins/qmldesigner/designercore"
+ "${CMAKE_SOURCE_DIR}/share/qtcreator/qml/qmlpuppet/interfaces"
+ "${CMAKE_SOURCE_DIR}/share/qtcreator/qml/qmlpuppet/types"
+ DEFINES
+ QT_CREATOR
+ QTCREATORDIR="${CMAKE_SOURCE_DIR}"
+ TESTSRCDIR="${CMAKE_CURRENT_SOURCE_DIR}"
+ SOURCES
+ ../data/testfiles.qrc
+ ../testview.cpp ../testview.h
+ testrewriterview.cpp testrewriterview.h
+ tst_testcore.cpp tst_testcore.h
+)