aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt b/tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt
new file mode 100644
index 0000000000..5d7f7c79bf
--- /dev/null
+++ b/tests/auto/qml/qmlprojectmanager/fileformat/CMakeLists.txt
@@ -0,0 +1,15 @@
+get_target_property(QmlProjectManagerSources QmlProjectManager SOURCES)
+foreach(source IN LISTS QmlProjectManagerSources)
+ if (source MATCHES "fileformat")
+ list(APPEND fileformat_sources "${CMAKE_SOURCE_DIR}/src/plugins/qmlprojectmanager/${source}")
+ endif()
+endforeach()
+
+add_qtc_test(tst_qml_fileformat
+ DEPENDS qmljs Utils
+ INCLUDES "${CMAKE_SOURCE_DIR}/src/plugins/qmlprojectmanager/fileformat"
+ DEFINES
+ QT_CREATOR
+ SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}"
+ SOURCES tst_fileformat.cpp ${fileformat_sources}
+)