aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/utils/process/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/utils/process/CMakeLists.txt')
-rw-r--r--tests/auto/utils/process/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/utils/process/CMakeLists.txt b/tests/auto/utils/process/CMakeLists.txt
new file mode 100644
index 00000000000..29bdf61451b
--- /dev/null
+++ b/tests/auto/utils/process/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_subdirectory(processtestapp)
+
+file(RELATIVE_PATH RELATIVE_TEST_PATH "${PROJECT_BINARY_DIR}" "${CMAKE_CURRENT_BINARY_DIR}")
+file(RELATIVE_PATH TEST_RELATIVE_LIBEXEC_PATH "/${RELATIVE_TEST_PATH}" "/${IDE_LIBEXEC_PATH}")
+
+add_qtc_test(tst_process
+ DEFINES "TEST_RELATIVE_LIBEXEC_PATH=\"${TEST_RELATIVE_LIBEXEC_PATH}\""
+ "PROCESS_TESTAPP=\"${CMAKE_CURRENT_BINARY_DIR}/processtestapp\""
+ DEPENDS Utils app_version
+ SOURCES tst_process.cpp
+ processtestapp/processtestapp.h
+ processtestapp/processtestapp.cpp
+)