summaryrefslogtreecommitdiffstats
path: root/src/quick3d/imports/scene3d/CMakeLists.txt
diff options
context:
space:
mode:
authorLi Xinwei <1326710505@qq.com>2021-08-06 20:01:56 +0800
committerLi Xinwei <1326710505@qq.com>2021-08-06 21:18:30 +0800
commit38338f5b89a6d75cb6056937a96dedbd6ea15a49 (patch)
tree71d53c23f1ed4c8a67bae35346838f73a3f09eb2 /src/quick3d/imports/scene3d/CMakeLists.txt
parentf52098f08a3c14e5dfa366a7955aeafa93a1dc3f (diff)
CMake: Don't give plugins PUBLIC usage requirements part 2
Amends ffccff03f347b971395cb212889921506d4a36f3 Pick-to: 6.2 Task-number: QTBUG-90819 Change-Id: Ic2cad9e60ecc73cf192fe5aadf770656fd9ed318 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/quick3d/imports/scene3d/CMakeLists.txt')
-rw-r--r--src/quick3d/imports/scene3d/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/quick3d/imports/scene3d/CMakeLists.txt b/src/quick3d/imports/scene3d/CMakeLists.txt
index 6e0be2764..b5e848f16 100644
--- a/src/quick3d/imports/scene3d/CMakeLists.txt
+++ b/src/quick3d/imports/scene3d/CMakeLists.txt
@@ -21,7 +21,7 @@ qt_internal_add_qml_module(qtquickscene3dplugin
scene3dsgmaterial.cpp scene3dsgmaterial_p.h
scene3dsgmaterialshader.cpp scene3dsgmaterialshader_p.h
scene3dsgnode.cpp scene3dsgnode_p.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DRender
Qt::3DRenderPrivate
@@ -42,17 +42,17 @@ qt_internal_add_qml_module(qtquickscene3dplugin
#####################################################################
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_input
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DInput
)
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_logic
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DLogic
)
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_animation
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DAnimation
)