summaryrefslogtreecommitdiffstats
path: root/src/quick3d/imports
diff options
context:
space:
mode:
authorLi Xinwei <1326710505@qq.com>2021-08-06 20:01:56 +0800
committerLi Xinwei <1326710505@qq.com>2021-08-06 21:18:30 +0800
commit38338f5b89a6d75cb6056937a96dedbd6ea15a49 (patch)
tree71d53c23f1ed4c8a67bae35346838f73a3f09eb2 /src/quick3d/imports
parentf52098f08a3c14e5dfa366a7955aeafa93a1dc3f (diff)
CMake: Don't give plugins PUBLIC usage requirements part 2
Amends ffccff03f347b971395cb212889921506d4a36f3 Pick-to: 6.2 Task-number: QTBUG-90819 Change-Id: Ic2cad9e60ecc73cf192fe5aadf770656fd9ed318 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/quick3d/imports')
-rw-r--r--src/quick3d/imports/animation/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/extras/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/input/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/logic/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/render/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/scene2d/CMakeLists.txt2
-rw-r--r--src/quick3d/imports/scene3d/CMakeLists.txt8
7 files changed, 10 insertions, 10 deletions
diff --git a/src/quick3d/imports/animation/CMakeLists.txt b/src/quick3d/imports/animation/CMakeLists.txt
index 407fc9708..1301b7abd 100644
--- a/src/quick3d/imports/animation/CMakeLists.txt
+++ b/src/quick3d/imports/animation/CMakeLists.txt
@@ -15,7 +15,7 @@ qt_internal_add_qml_module(quick3danimationplugin
INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qt3dquick3danimationplugin.cpp qt3dquick3danimationplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DAnimation
Qt::3DCore
Qt::3DQuick
diff --git a/src/quick3d/imports/extras/CMakeLists.txt b/src/quick3d/imports/extras/CMakeLists.txt
index 886718038..9263f632b 100644
--- a/src/quick3d/imports/extras/CMakeLists.txt
+++ b/src/quick3d/imports/extras/CMakeLists.txt
@@ -17,7 +17,7 @@ qt_internal_add_qml_module(quick3dextrasplugin
Qt3D.Logic/2.0
SOURCES
qt3dquick3dextrasplugin.cpp qt3dquick3dextrasplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DCorePrivate
Qt::3DExtras
diff --git a/src/quick3d/imports/input/CMakeLists.txt b/src/quick3d/imports/input/CMakeLists.txt
index c02f2a68c..3742a6ed7 100644
--- a/src/quick3d/imports/input/CMakeLists.txt
+++ b/src/quick3d/imports/input/CMakeLists.txt
@@ -15,7 +15,7 @@ qt_internal_add_qml_module(quick3dinputplugin
INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qt3dquick3dinputplugin.cpp qt3dquick3dinputplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DInput
Qt::3DInputPrivate
diff --git a/src/quick3d/imports/logic/CMakeLists.txt b/src/quick3d/imports/logic/CMakeLists.txt
index d6267cd2b..00e3276ed 100644
--- a/src/quick3d/imports/logic/CMakeLists.txt
+++ b/src/quick3d/imports/logic/CMakeLists.txt
@@ -15,7 +15,7 @@ qt_internal_add_qml_module(quick3dlogicplugin
INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qt3dquick3dlogicplugin.cpp qt3dquick3dlogicplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
3DLogic
Qt::Core
diff --git a/src/quick3d/imports/render/CMakeLists.txt b/src/quick3d/imports/render/CMakeLists.txt
index 23df017da..e37a04912 100644
--- a/src/quick3d/imports/render/CMakeLists.txt
+++ b/src/quick3d/imports/render/CMakeLists.txt
@@ -15,7 +15,7 @@ qt_internal_add_qml_module(quick3drenderplugin
INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qt3dquick3drenderplugin.cpp qt3dquick3drenderplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DQuick
Qt::3DQuickPrivate
diff --git a/src/quick3d/imports/scene2d/CMakeLists.txt b/src/quick3d/imports/scene2d/CMakeLists.txt
index c2a3764fc..89c4ef865 100644
--- a/src/quick3d/imports/scene2d/CMakeLists.txt
+++ b/src/quick3d/imports/scene2d/CMakeLists.txt
@@ -15,7 +15,7 @@ qt_internal_add_qml_module(qtquickscene2dplugin
INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
qtquickscene2dplugin.cpp qtquickscene2dplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DQuickScene2D
Qt::3DQuickScene2DPrivate
diff --git a/src/quick3d/imports/scene3d/CMakeLists.txt b/src/quick3d/imports/scene3d/CMakeLists.txt
index 6e0be2764..b5e848f16 100644
--- a/src/quick3d/imports/scene3d/CMakeLists.txt
+++ b/src/quick3d/imports/scene3d/CMakeLists.txt
@@ -21,7 +21,7 @@ qt_internal_add_qml_module(qtquickscene3dplugin
scene3dsgmaterial.cpp scene3dsgmaterial_p.h
scene3dsgmaterialshader.cpp scene3dsgmaterialshader_p.h
scene3dsgnode.cpp scene3dsgnode_p.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DRender
Qt::3DRenderPrivate
@@ -42,17 +42,17 @@ qt_internal_add_qml_module(qtquickscene3dplugin
#####################################################################
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_input
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DInput
)
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_logic
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DLogic
)
qt_internal_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_animation
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DAnimation
)