summaryrefslogtreecommitdiffstats
path: root/src/activeqt/container/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-27 08:15:54 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-28 07:49:05 +0200
commitf5982f32cd38fb8b63522fe4390ac10eb2b1b157 (patch)
tree91eb07909dfffd6528458d6efd9597f9ce893c26 /src/activeqt/container/CMakeLists.txt
parent592dcba7276b129220a27af3bef44a736ca347ba (diff)
Introduce private classes for QAxWidget, QAxObject
It solves the problem of calling virtual clear() from the destructor and prepares for further changes. Change-Id: Icb8530c70e451ab5f27443fbd54fb3b3cf5e8c03 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/activeqt/container/CMakeLists.txt')
-rw-r--r--src/activeqt/container/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/activeqt/container/CMakeLists.txt b/src/activeqt/container/CMakeLists.txt
index ddb16d8..0f2ac6d 100644
--- a/src/activeqt/container/CMakeLists.txt
+++ b/src/activeqt/container/CMakeLists.txt
@@ -12,12 +12,12 @@ qt_add_module(AxContainer
../shared/qaxtypes.cpp ../shared/qaxtypes_p.h
qaxbase.cpp qaxbase.h qaxbase_p.h
qaxdump.cpp
- qaxobject.cpp qaxobject.h
+ qaxobject.cpp qaxobject.h qaxobject_p.h
qaxobjectinterface.h
qaxscript.cpp qaxscript.h
qaxscriptwrapper.cpp
qaxselect.cpp qaxselect.h qaxselect.ui
- qaxwidget.cpp qaxwidget.h
+ qaxwidget.cpp qaxwidget.h qaxwidget_p.h
LIBRARIES
Qt::AxBasePrivate
Qt::CorePrivate