summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Griebl <robert.griebl@qt.io>2024-02-07 02:42:37 +0100
committerRobert Griebl <robert.griebl@qt.io>2024-03-05 18:43:20 +0000
commitea49063b02733e3ec8caaf39a610fb70d24d5b0a (patch)
treefdf8f60f437789a5f2889c49cde414e776365e83 /src/3rdparty/CMakeLists.txt
parent9c19aa9a3ae7d1eb60620e912f4c2a26cfb2b5a6 (diff)
Add libdbus to 3rdparty for Windows/macOS
On startup, we check if a libdbus-1 is provided by the system. If not we try to load our build instead, which will then be picked up by QtDBus later on. This enables us to use appman-controller in the QtCreator integration even on Windows and macOS. Change-Id: Ib832198ffd9c9e08e14d3c35cdcb4dff17f3b656 Pick-to: 6.7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'src/3rdparty/CMakeLists.txt')
-rw-r--r--src/3rdparty/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/3rdparty/CMakeLists.txt b/src/3rdparty/CMakeLists.txt
index 6d0e4e17..7cea3584 100644
--- a/src/3rdparty/CMakeLists.txt
+++ b/src/3rdparty/CMakeLists.txt
@@ -7,6 +7,10 @@ if(NOT QT_FEATURE_am_system_libyaml)
add_subdirectory(libyaml)
endif()
+if(QT_FEATURE_am_libdbus)
+ add_subdirectory(libdbus)
+endif()
+
if(QT_FEATURE_am_libbacktrace)
add_subdirectory(libbacktrace)
endif()