summaryrefslogtreecommitdiffstats
path: root/tests/auto/package-server-tool/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Griebl <robert.griebl@qt.io>2024-03-02 22:24:02 +0100
committerRobert Griebl <robert.griebl@qt.io>2024-03-05 12:30:26 +0100
commit96e290e617e20127002ce3e3a5f151d128cc3189 (patch)
treebaf8e735bae4a30eff5f02f44ecfad0dce60cea9 /tests/auto/package-server-tool/CMakeLists.txt
parent607b74cfea26d45285c36314592927e03c9dfeff (diff)
tests: add a test for the new package-server tool
Also fixes three bugs found in the server with those tests. Change-Id: Ic2ca10cc2ee66d644c97b4b613e59521dfcec7eb Pick-to: 6.7 Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'tests/auto/package-server-tool/CMakeLists.txt')
-rw-r--r--tests/auto/package-server-tool/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/auto/package-server-tool/CMakeLists.txt b/tests/auto/package-server-tool/CMakeLists.txt
new file mode 100644
index 00000000..d104cc7a
--- /dev/null
+++ b/tests/auto/package-server-tool/CMakeLists.txt
@@ -0,0 +1,11 @@
+
+qt_internal_add_test(tst_package-server-tool
+ SOURCES
+ ../error-checking.h
+ tst_package-server-tool.cpp
+ DEFINES
+ AM_TESTDATA_DIR="${CMAKE_CURRENT_BINARY_DIR}/../../data/"
+ LIBRARIES
+ Qt::Network
+ Qt::AppManCommonPrivate
+)