summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-02-15 13:16:35 +0100
committerSimon Hausmann <simon.hausmann@qt.io>2019-02-18 16:19:10 +0000
commit0b13578dcbe529f641d6bacb926d4ab10b5f5e91 (patch)
tree0bd66a6b5e178badd07caeb3bdeceaee511481ac /CMakeLists.txt
parentaf7fe32ebd2140c8940373a579e7160e4ce73b57 (diff)
Skip the qmake build when cross-compiling
Change-Id: I24da7eb9587235aa937a984e91a833284b4f28e5 Reviewed-by: Kevin Funk <kevin.funk@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8946d55d83..1eab8afcca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,7 +40,9 @@ if (BUILD_TESTING)
add_subdirectory(tests)
endif()
-add_subdirectory(qmake)
+if (NOT CMAKE_CROSSCOMPILING)
+ add_subdirectory(qmake)
+endif()
option(BUILD_EXAMPLES "Build Qt examples" ON)
if (BUILD_EXAMPLES)