summaryrefslogtreecommitdiffstats
path: root/cmake/tests/features/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2018-11-22 11:35:17 +0100
committerTobias Hunger <tobias.hunger@qt.io>2018-11-22 12:45:35 +0000
commitc68e5fc59ba8f0fd8b782a37df20ab9b7d7ecafa (patch)
tree4295a444826c3ca4be6fa895ed15a55ea38e42f8 /cmake/tests/features/CMakeLists.txt
parentbdb5e2a48ea206005eaa8305b7517b2843f2aba1 (diff)
CMake: Add macro to generate cmake build-only tests
In addition to cmake tests that run cmake, build and then run the tests of that project, also add a macro for tests that only run cmake. Use this new kind of test for the existing tests. Change-Id: I465600974ed4114e724988b309404ccd3db2e0cb Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
Diffstat (limited to 'cmake/tests/features/CMakeLists.txt')
-rw-r--r--cmake/tests/features/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/cmake/tests/features/CMakeLists.txt b/cmake/tests/features/CMakeLists.txt
index e255b209c9..3cda8ebe26 100644
--- a/cmake/tests/features/CMakeLists.txt
+++ b/cmake/tests/features/CMakeLists.txt
@@ -40,5 +40,3 @@ include(QtPostProcess)
## Print a feature summary:
feature_summary(WHAT PACKAGES_FOUND PACKAGES_NOT_FOUND FATAL_ON_MISSING_REQUIRED_PACKAGES)
-
-add_executable(features ../main.cpp)