summaryrefslogtreecommitdiffstats
path: root/examples/opengl/threadedqopenglwidget/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2022-01-24 16:38:02 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2022-01-25 15:54:05 +0100
commitf172b964f6d9fc8cadeb7b5efeb3f59c0f8f16f6 (patch)
tree2824827877b7971fe8b4834acdbada107ca5b26b /examples/opengl/threadedqopenglwidget/CMakeLists.txt
parent2d95b7534530fec1e1e52ef7e8be289abb48b822 (diff)
threadedqopenglwidget example: Split out class Renderer
This makes the code clearer and decouples it from the GLWidget. As a drive-by, add a global shortcut to close. Pick-to: 6.3 6.2 Change-Id: I3469d29bc367acc17c5f8acf9d46219259b8315b Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'examples/opengl/threadedqopenglwidget/CMakeLists.txt')
-rw-r--r--examples/opengl/threadedqopenglwidget/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/opengl/threadedqopenglwidget/CMakeLists.txt b/examples/opengl/threadedqopenglwidget/CMakeLists.txt
index c8a5d52d4a..187813afa1 100644
--- a/examples/opengl/threadedqopenglwidget/CMakeLists.txt
+++ b/examples/opengl/threadedqopenglwidget/CMakeLists.txt
@@ -12,6 +12,7 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/threadedqopenglwidget")
find_package(Qt6 REQUIRED COMPONENTS Core Gui OpenGL OpenGLWidgets Widgets)
qt_add_executable(threadedqopenglwidget
+ renderer.cpp renderer.h
glwidget.cpp glwidget.h
main.cpp
mainwindow.cpp mainwindow.h