summaryrefslogtreecommitdiffstats
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 12:11:47 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-20 12:29:53 +0000
commit432f7232e3b1a4b2668e31e1ccfdd4d404b49960 (patch)
tree75d91683829b39200232d1c7865ee1d0c7932c59 /src/dbus/CMakeLists.txt
parentdedc645510ff8cf11228b569763bf36cd7cedb1a (diff)
CMake: Add public dependency from Qt::Dbus to Qt::Core
Anything that uses Qt::Dbus also needs to link to Qt::Core, so encode that in the target. Change-Id: Ibc984d5b5e118aae8d1c0d21117fcff1664b0ae3 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
index dd01256530..d17667a26a 100644
--- a/src/dbus/CMakeLists.txt
+++ b/src/dbus/CMakeLists.txt
@@ -43,6 +43,8 @@ add_qt_module(DBus
QT_NO_FOREACH
LIBRARIES
Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Core # special case
# MODULE_CONFIG = "dbusadaptors" "dbusinterfaces"
# _LOADED = "qt_module"
)