summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-05-10 13:03:38 +0200
committerLiang Qi <liang.qi@qt.io>2021-05-10 21:19:46 +0000
commitedceff30b4093e2bef6e80c7552edf595134f351 (patch)
treecefb89ea882051550614adbc2731247ca095896c /src/gui/CMakeLists.txt
parent066a1de8e7b198dbe99cdecefeae94d5f0e5f289 (diff)
Move QtX11Extras into QtGui as private API
from qt/qtx11extras 0e67fb41cfc4b4bfbaa7dc75f8ddebdf5a08e836. The plan is to expose these as native interfaces, so this is a first step. Task-number: QTBUG-83251 Change-Id: Iecba8db9a4f616a08a3750ddaae08cc30ec66f89 Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index cc23d1ff88..217ee4a4af 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -967,6 +967,11 @@ qt_internal_extend_target(Gui CONDITION UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
platform/unix/qgenericunixservices.cpp platform/unix/qgenericunixservices_p.h
)
+qt_internal_extend_target(Gui CONDITION UNIX AND (QT_FEATURE_xcb)
+ SOURCES
+ platform/unix/qtx11extras.cpp platform/unix/qtx11extras_p.h
+)
+
qt_internal_extend_target(Gui CONDITION TARGET Qt::DBus AND UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
LIBRARIES
Qt::DBus