summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index cc23d1ff88..217ee4a4af 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -967,6 +967,11 @@ qt_internal_extend_target(Gui CONDITION UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
platform/unix/qgenericunixservices.cpp platform/unix/qgenericunixservices_p.h
)
+qt_internal_extend_target(Gui CONDITION UNIX AND (QT_FEATURE_xcb)
+ SOURCES
+ platform/unix/qtx11extras.cpp platform/unix/qtx11extras_p.h
+)
+
qt_internal_extend_target(Gui CONDITION TARGET Qt::DBus AND UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
LIBRARIES
Qt::DBus