summaryrefslogtreecommitdiffstats
path: root/src/platformheaders/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-07-03 15:40:47 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-07-06 11:52:14 +0200
commit8dd6957cd7a1d86714b32b97dffe603a8636848a (patch)
tree7793275d713c3341e01bb8dafc3d1ec9af2f58db /src/platformheaders/CMakeLists.txt
parent18cfabafa615e42c4af092edca5bb35eced4de5e (diff)
Make QtPlatformHeaders a private module
The APIs will be reintroduced as part of the new platform interface API where appropriate. Clients that still depend on the platform headers can include it via QT += platformheaders-private. Change-Id: Ifbd836d833d19f3cf48cd4f933d7fe754c06d2d9 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/platformheaders/CMakeLists.txt')
-rw-r--r--src/platformheaders/CMakeLists.txt26
1 files changed, 20 insertions, 6 deletions
diff --git a/src/platformheaders/CMakeLists.txt b/src/platformheaders/CMakeLists.txt
index 820bbb71a5..63bb60576f 100644
--- a/src/platformheaders/CMakeLists.txt
+++ b/src/platformheaders/CMakeLists.txt
@@ -1,13 +1,27 @@
# Generated from platformheaders.pro.
-# special case begin
-
-# FIXME Add the rest of the stuff? I don't think any other stuff is needed?
-
-qt_add_module(PlatformHeaders HEADER_MODULE)
+#####################################################################
+## PlatformHeaders Module:
+#####################################################################
+qt_add_module(PlatformHeaders
+ HEADER_MODULE
+ # special case begin
+ # SOURCES
+ # cocoafunctions/qcocoawindowfunctions_p.h
+ # eglfsfunctions/qeglfsfunctions_p.h
+ # helper/qplatformheaderhelper_p.h
+ # linuxfbfunctions/qlinuxfbfunctions_p.h
+ # waylandfunctions/qwaylandwindowfunctions_p.h
+ # windowsfunctions/qwindowswindowfunctions_p.h
+ # xcbfunctions/qxcbscreenfunctions_p.h
+ # xcbfunctions/qxcbwindowfunctions_p.h
+ # special case end
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+)
qt_add_docs(PlatformHeaders
doc/qtplatformheaders.qdocconf
)
-# special case end