summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 18:09:46 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 23:22:57 +0200
commita97a8fcc1a9b832fee2ed0e01258e1664a3e3e69 (patch)
treef8f08841827a7e12a53591cb2ea183a6b3d510e7 /src/platformsupport/CMakeLists.txt
parent77771116a4d43e4832494785bc0abde8f3d8fd58 (diff)
CMake: Regenerate src/platformsupport
Change-Id: If7b5359c457edee814dc7d3a71cf47ce052e6c5e Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index ae75c87c97..b18b27f5fb 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -10,7 +10,7 @@ if (QT_FEATURE_dbus)
add_subdirectory(linuxofono)
endif()
# special case end
-if(APPLE OR QT_FEATURE_freetype OR WIN32)
+if(WIN32 OR (QT_FEATURE_freetype AND NOT APPLE))
add_subdirectory(fontdatabases)
endif()
if(QT_FEATURE_evdev OR QT_FEATURE_integrityhid OR QT_FEATURE_libinput OR QT_FEATURE_tslib OR QT_FEATURE_xkbcommon)