summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index ae75c87c97..b18b27f5fb 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -10,7 +10,7 @@ if (QT_FEATURE_dbus)
add_subdirectory(linuxofono)
endif()
# special case end
-if(APPLE OR QT_FEATURE_freetype OR WIN32)
+if(WIN32 OR (QT_FEATURE_freetype AND NOT APPLE))
add_subdirectory(fontdatabases)
endif()
if(QT_FEATURE_evdev OR QT_FEATURE_integrityhid OR QT_FEATURE_libinput OR QT_FEATURE_tslib OR QT_FEATURE_xkbcommon)