summaryrefslogtreecommitdiffstats
path: root/src/plugins/bearer/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-06 15:02:40 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-05-06 14:46:11 +0000
commit0434b7fb38c33b26700daabe31a29ab0cd4294d7 (patch)
tree50a328ee258ed7da5e0734a47219bc941f100815 /src/plugins/bearer/CMakeLists.txt
parent9ffcc761887f0088ae6226098723818843f0d287 (diff)
CMake: Regenerate src/plugins/bearer
Change-Id: I6c900247eb03b8afc3f299b5dbca5bac64527a52 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/bearer/CMakeLists.txt')
-rw-r--r--src/plugins/bearer/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/plugins/bearer/CMakeLists.txt b/src/plugins/bearer/CMakeLists.txt
index ec860de2cb..88e4f4206e 100644
--- a/src/plugins/bearer/CMakeLists.txt
+++ b/src/plugins/bearer/CMakeLists.txt
@@ -1,9 +1,11 @@
-if (NOT ANDROID AND LINUX AND QT_FEATURE_dbus)
+# Generated from bearer.pro.
+
+if(NOT ANDROID AND LINUX AND TARGET Qt::DBus) # special case
add_subdirectory(generic)
add_subdirectory(connman)
add_subdirectory(networkmanager)
-elseif(ANDROID AND NOT ANDROID_EMBEDDED)
-# TODO add_subdirectory(android)
-else()
+else if(ANDROID AND NOT ANDROID_EMBEDDED) # special case
+ add_subdirectory(android)
+else() # special case
add_subdirectory(generic)
endif()