summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2021-06-03 15:51:07 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2021-06-11 19:23:03 +0200
commitd245e3a7883ccb2c8beabbca5094de54ec963644 (patch)
tree731cd57605802d03d3193540db147727ad38a077 /src/plugins/networkinformation/networklistmanager/CMakeLists.txt
parentf6f6d06028a62fef3e0d8458903549499fced45a (diff)
QNetworkInformation: Rename the plugins and type
To better match other plugins in Qt Pick-to: 6.2 Change-Id: I6ab19603f13c80a8afe4fe69f64669559a0eea15 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Yuhang Zhao <2546789017@qq.com>
Diffstat (limited to 'src/plugins/networkinformation/networklistmanager/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformation/networklistmanager/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
new file mode 100644
index 0000000000..52f19aefa9
--- /dev/null
+++ b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
@@ -0,0 +1,13 @@
+qt_internal_add_plugin(QNLMNIPlugin
+ OUTPUT_NAME networklistmanager
+ CLASS_NAME QNetworkListManagerNetworkInformationBackendFactory
+ TYPE networkinformation
+ DEFAULT_IF WINDOWS AND QT_FEATURE_networklistmanager
+ SOURCES qnetworklistmanagernetworkinformationbackend.cpp
+ PUBLIC_LIBRARIES
+ Qt::NetworkPrivate
+)
+
+# Don't repeat the target name in AUTOGEN_BUILD_DIR to work around issues with overlong paths.
+set_property(TARGET QNLMNIPlugin PROPERTY
+ AUTOGEN_BUILD_DIR "${CMAKE_CURRENT_BINARY_DIR}/autogen")