summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/networkinformation/networklistmanager/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformation/networklistmanager/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/plugins/networkinformation/networklistmanager/CMakeLists.txt b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
new file mode 100644
index 0000000000..52f19aefa9
--- /dev/null
+++ b/src/plugins/networkinformation/networklistmanager/CMakeLists.txt
@@ -0,0 +1,13 @@
+qt_internal_add_plugin(QNLMNIPlugin
+ OUTPUT_NAME networklistmanager
+ CLASS_NAME QNetworkListManagerNetworkInformationBackendFactory
+ TYPE networkinformation
+ DEFAULT_IF WINDOWS AND QT_FEATURE_networklistmanager
+ SOURCES qnetworklistmanagernetworkinformationbackend.cpp
+ PUBLIC_LIBRARIES
+ Qt::NetworkPrivate
+)
+
+# Don't repeat the target name in AUTOGEN_BUILD_DIR to work around issues with overlong paths.
+set_property(TARGET QNLMNIPlugin PROPERTY
+ AUTOGEN_BUILD_DIR "${CMAKE_CURRENT_BINARY_DIR}/autogen")