summaryrefslogtreecommitdiffstats
path: root/src/tools/bootstrap/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-03-11 12:34:52 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-03-18 15:34:52 +0000
commit3f03917b54ace1041f7a640dc65b452b0275fafc (patch)
treecdeed63c0b1afcd906e07352b6e829fbaa9d7133 /src/tools/bootstrap/CMakeLists.txt
parent4f1a155909dfcba7353ebe9eee669d65336bd943 (diff)
Fix Windows build
- Fix qmake build - Fix QtNetwork moc-ing, by including the moc files inside the cpp files - Fix sql odbc plugin by including QT_PLUGIN define - Fix Boostrap to link against the Platform target, to get the correct Unicode and WIN64 defines. - Fix vulkan headers to be found - Fix freetype bzip and png unresolved symbols / linker issues when building minimal platform plugin (also need to make sure to use the vcpkg toolchain instead of CMAKE_PREFIX_PATH because then find_package is overridden, which does magic to properly propagate static library dependencies). - Fix qfilesystementry test not to be built without private tests feature (it led to undefined symbols issues). - Make sure to remove QT_NO_CAST_TO_ASCII define when building QtCore, so that the qstringbuilder3 test builds successfully. Task-number: QTBUG-74140 Change-Id: I353d08392b604d55f8e62cdd8696d1e19a3c084a Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/tools/bootstrap/CMakeLists.txt')
-rw-r--r--src/tools/bootstrap/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/tools/bootstrap/CMakeLists.txt b/src/tools/bootstrap/CMakeLists.txt
index 4bbbe08ea5..69e334c492 100644
--- a/src/tools/bootstrap/CMakeLists.txt
+++ b/src/tools/bootstrap/CMakeLists.txt
@@ -97,6 +97,7 @@ extend_target(Bootstrap
$<TARGET_PROPERTY:XmlPrivate,INTERFACE_INCLUDE_DIRECTORIES>
PUBLIC_LIBRARIES # special case
ZLIB::ZLIB
+ Qt::Platform
# CONFIG = "minimal_syncqt" "internal_module" "force_bootstrap" "gc_binaries"
# INSTALLS = "lib"
# MODULE_CONFIG = "gc_binaries"