summaryrefslogtreecommitdiffstats
path: root/src/tools/cmake_automoc_parser/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-05-02 12:48:37 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2022-05-06 22:06:22 +0200
commitf087e63bf585f51d6c530dd58a57155835e6df2c (patch)
tree766255f90230080f3725b0691ac0b36fed255bd3 /src/tools/cmake_automoc_parser/CMakeLists.txt
parenta1437ce16255b35f0b5fa1ace5194266a53ee36b (diff)
CMake: Make possible building Qt tools without the use of core library
Replace BOOTSTRAP option with the single value CORE_LIBRARY argument in qt_internal_add_tool and qt_internal_add_executable functions. The introduced argument now may accept 'Bootstap' and 'None' values. Use 'Bootstap' to link Qt::Boostrap library instead Qt::Core or 'None' to avoid any core library linking. This is useful for tools that need to use the CMake deployment routines, but not require the Qt::Core functionality. Task-number: QTBUG-87480 Change-Id: I64a8b17f16ac5fe43c6b385252dc21def0c88d2c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/tools/cmake_automoc_parser/CMakeLists.txt')
-rw-r--r--src/tools/cmake_automoc_parser/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/tools/cmake_automoc_parser/CMakeLists.txt b/src/tools/cmake_automoc_parser/CMakeLists.txt
index 927d54a2fd..3cc832d582 100644
--- a/src/tools/cmake_automoc_parser/CMakeLists.txt
+++ b/src/tools/cmake_automoc_parser/CMakeLists.txt
@@ -4,7 +4,7 @@
qt_get_tool_target_name(target_name cmake_automoc_parser)
qt_internal_add_tool(${target_name}
- BOOTSTRAP
+ CORE_LIBRARY Bootstrap
INSTALL_DIR "${INSTALL_LIBEXECDIR}"
TOOLS_TARGET Core # special case
SOURCES