summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-04-02 16:03:18 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-04-03 09:00:08 +0000
commit547c7f8ca5c13564460c4c47611c9681ad8b022b (patch)
treec0cf560fad0465d0c44dc9b8f456f1254335df9a /src/widgets/CMakeLists.txt
parent9a7de16fac8d4f2bcbc635db4a83ac78380287fc (diff)
Fix architecture conditions
The actual variable that contains the architecture is TEST_architecture_arch. TEST_architecture only contains the value if the test was performed or not. Fix the conversion script and all the generated files. Change-Id: Icb3480832cab894948f4fef03b8bc8187cab6152 Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index afb1cd8e71..a92da0f32e 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -266,7 +266,7 @@ add_qt_resource(Widgets "qstyle1" PREFIX "/qt-project.org/styles/macstyle" BASE
## Scopes:
#####################################################################
-extend_target(Widgets CONDITION MSVC AND (TEST_architecture STREQUAL "i386")
+extend_target(Widgets CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")
LINK_OPTIONS
"/BASE:0x65000000"
)