summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <Alexander.Richardson@cl.cam.ac.uk>2020-09-03 15:01:05 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-09-15 20:05:32 +0200
commit44920e7fb272f49423c925555e8ae3bc38ffd8a4 (patch)
tree35d318f26cbdc006f7eaf4ff993e3e497b3f25b3 /tests/auto/CMakeLists.txt
parent93fc3afe71467ca6aeffa41d7a6f4a170f82b62e (diff)
CMake: Fix building with -DQT_FEATURE_gui=OFF
Some CMake files currently assume that QtGui is always enabled and we get a configure-time failure without these changes. Task-number: QTBUG-86053 Change-Id: I28e32c180c32221f32519017bac6b518a19d5983 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 49c2ff4a2c..2452e1a5d8 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -17,7 +17,11 @@ if (NOT CMAKE_CROSSCOMPILE AND QT_FEATURE_process)
add_subdirectory(tools)
endif()
add_subdirectory(corelib)
-add_subdirectory(cmake)
+# special case begin
+if (TARGET Qt::Xml AND TARGET Qt::Sql AND TARGET Qt::Network)
+ add_subdirectory(cmake)
+endif()
+# special case end
if (TARGET Qt::Concurrent)
add_subdirectory(concurrent)
endif()