summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 49c2ff4a2c..2452e1a5d8 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -17,7 +17,11 @@ if (NOT CMAKE_CROSSCOMPILE AND QT_FEATURE_process)
add_subdirectory(tools)
endif()
add_subdirectory(corelib)
-add_subdirectory(cmake)
+# special case begin
+if (TARGET Qt::Xml AND TARGET Qt::Sql AND TARGET Qt::Network)
+ add_subdirectory(cmake)
+endif()
+# special case end
if (TARGET Qt::Concurrent)
add_subdirectory(concurrent)
endif()