summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2018-10-24 15:20:27 +0200
committerTobias Hunger <tobias.hunger@qt.io>2018-11-01 11:48:46 +0000
commite9c45bbdddd4df005bdaa5eea9740d351e6eaea2 (patch)
tree23765d4650f8f349d1f32e0fe4b1bc678cae7568 /tests/auto/CMakeLists.txt
parent345e6b0213b1273b698163064f80d33bc7ce64a9 (diff)
Begin port of qtbase to CMake
Done-by: Alexandru Croitor <alexandru.croitor@qt.io> Done-by: Frederik Gladhorn <frederik.gladhorn@qt.io> Done-by: Kevin Funk <kevin.funk@kdab.com> Done-by: Mikhail Svetkin <mikhail.svetkin@qt.io> Done-by: Simon Hausmann <simon.hausmann@qt.io> Done-by: Tobias Hunger <tobias.hunger@qt.io> Done-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Done-by: Volker Krause <volker.krause@kdab.com> Change-Id: Ida4f8bd190f9a4849a1af7b5b7981337a5df5310 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Mikhail Svetkin <mikhail.svetkin@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
new file mode 100644
index 0000000000..5ee23c0023
--- /dev/null
+++ b/tests/auto/CMakeLists.txt
@@ -0,0 +1,55 @@
+# Generated from auto.pro.
+
+if (NOT APPLE_UIKIT)
+ add_subdirectory("corelib")
+endif()
+if (QT_FEATURE_dbus)
+ set(run_dbus_tests ON)
+ if(NOT CMAKE_CROSSCOMPILING AND TARGET Qt::DBus)
+ execute_process(COMMAND dbus-send --session --type=signal / local.AutotestCheck.Hello
+ RESULT_VARIABLE dbus_session_test
+ OUTPUT_QUIET ERROR_QUIET)
+ if(NOT "${dbus_session_test}" STREQUAL "0")
+ set(run_dbus_tests OFF)
+ if(QT_FEATURE_dbus_linked)
+ message(SEND_ERROR "QtDBus is enabled but session bus is not available for testing. Please check the installation.")
+ else()
+ message(WARNING "QtDBus is enabled with runtime support, but session bus is not available. Skipping QtDBus tests.")
+ endif()
+ endif()
+ endif()
+ if(run_dbus_tests)
+ add_subdirectory("dbus")
+ endif()
+endif()
+if (NOT APPLE_UIKIT AND QT_FEATURE_gui)
+ add_subdirectory("gui")
+endif()
+if (QT_FEATURE_network AND NOT WINRT)
+# add_subdirectory("network")
+endif()
+if (TARGET Qt::OpenGL AND NOT WINRT)
+ add_subdirectory("opengl")
+endif()
+if (QT_FEATURE_sql)
+# add_subdirectory("sql")
+endif()
+add_subdirectory("testlib")
+if (NOT CMAKE_CROSSCOMPILE AND QT_FEATURE_process)
+# add_subdirectory("tools")
+endif()
+if (QT_FEATURE_xml)
+# add_subdirectory("xml")
+endif()
+if (QT_FEATURE_concurrent)
+# add_subdirectory("concurrent")
+endif()
+# add_subdirectory("other")
+if (QT_FEATURE_widgets)
+ add_subdirectory("widgets")
+endif()
+if (QT_FEATURE_printsupport)
+# add_subdirectory("printsupport")
+endif()
+# add_subdirectory("cmake") ## FIXME: Does this still make sense in this form?
+# add_subdirectory("installed_cmake") ## FIXME: Does this still make sense in this form?