summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_openglextensions_module/CMakeLists.txt
diff options
context:
space:
mode:
authorEirik Aavitsland <eirik.aavitsland@qt.io>2020-06-09 14:00:13 +0200
committerEirik Aavitsland <eirik.aavitsland@qt.io>2020-06-10 09:35:04 +0200
commit56f40cdca6b589beec5c2cb803633985ca4c59d1 (patch)
tree77ba78451d6040caa455d178dd42d4427a806b7f /tests/auto/cmake/test_openglextensions_module/CMakeLists.txt
parent122d66f69fa44e11202fccdab076fe1ec368f971 (diff)
Remove the openglextensions module
[ChangeLog][General] The QtOpenglExtensions module has been discontinued. It provided only convenience functionality for certain direct OpenGL usage. With the new RHI graphics API abstraction, that is no longer a primary use case. Applications that still need to access that API have a number of alternative options, including QOpenGLExtraFunctions. Fixes: QTBUG-84085 Change-Id: I272af61c69ebcec207b576d67d08b59623d485ec Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'tests/auto/cmake/test_openglextensions_module/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_openglextensions_module/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/tests/auto/cmake/test_openglextensions_module/CMakeLists.txt b/tests/auto/cmake/test_openglextensions_module/CMakeLists.txt
deleted file mode 100644
index 3c23bce2bd..0000000000
--- a/tests/auto/cmake/test_openglextensions_module/CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-
-cmake_minimum_required(VERSION 2.8)
-
-project(test_openglextensions_module)
-
-find_package(Qt5OpenGLExtensions 5.1.0 REQUIRED)
-
-include_directories(
- ${Qt5OpenGLExtensions_INCLUDE_DIRS}
-)
-
-add_definitions(
- ${Qt5OpenGLExtensions_DEFINITIONS}
-)
-
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5OpenGLExtensions_EXECUTABLE_COMPILE_FLAGS}")
-
-add_executable(mainapp main.cpp)
-
-target_link_libraries(mainapp
- ${Qt5OpenGLExtensions_LIBRARIES}
-)