summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qzip/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-02-10 20:21:30 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-02-11 21:54:44 +0100
commit815bc61626825ec5572d642e6baaec9158d81044 (patch)
tree372bf9774d10aaa09238dd43866ded06cb43fa14 /tests/auto/gui/text/qzip/CMakeLists.txt
parentfdf5d11ff6f3f5034d7d7f7664f4cc76deb26ef5 (diff)
Cleanup tests that add test data to resources explicitly
Remove Integrity and Android specific code that explicitly adds test data to the resource files. qt_internal_add_test functions implicitly adds test data to resources for Android and Integrity platforms by default. Change-Id: Ia1d58755b47442e1953462e38606f70fec262368 Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/gui/text/qzip/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qzip/CMakeLists.txt23
1 files changed, 4 insertions, 19 deletions
diff --git a/tests/auto/gui/text/qzip/CMakeLists.txt b/tests/auto/gui/text/qzip/CMakeLists.txt
index 7240a611d2..dceda50251 100644
--- a/tests/auto/gui/text/qzip/CMakeLists.txt
+++ b/tests/auto/gui/text/qzip/CMakeLists.txt
@@ -5,7 +5,10 @@
#####################################################################
# Collect test data
-list(APPEND test_data "testdata")
+file(GLOB_RECURSE test_data
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*
+)
qt_internal_add_test(tst_qzip
SOURCES
@@ -15,21 +18,3 @@ qt_internal_add_test(tst_qzip
Qt::GuiPrivate
TESTDATA ${test_data}
)
-
-## Scopes:
-#####################################################################
-
-if(ANDROID)
- # Resources:
- set(testdata_resource_files
- "testdata/symlink.zip"
- "testdata/test.zip"
- )
-
- qt_internal_add_resource(tst_qzip "testdata"
- PREFIX
- "/"
- FILES
- ${testdata_resource_files}
- )
-endif()