summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qzip/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qzip/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qzip/CMakeLists.txt23
1 files changed, 4 insertions, 19 deletions
diff --git a/tests/auto/gui/text/qzip/CMakeLists.txt b/tests/auto/gui/text/qzip/CMakeLists.txt
index 7240a611d2..dceda50251 100644
--- a/tests/auto/gui/text/qzip/CMakeLists.txt
+++ b/tests/auto/gui/text/qzip/CMakeLists.txt
@@ -5,7 +5,10 @@
#####################################################################
# Collect test data
-list(APPEND test_data "testdata")
+file(GLOB_RECURSE test_data
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*
+)
qt_internal_add_test(tst_qzip
SOURCES
@@ -15,21 +18,3 @@ qt_internal_add_test(tst_qzip
Qt::GuiPrivate
TESTDATA ${test_data}
)
-
-## Scopes:
-#####################################################################
-
-if(ANDROID)
- # Resources:
- set(testdata_resource_files
- "testdata/symlink.zip"
- "testdata/test.zip"
- )
-
- qt_internal_add_resource(tst_qzip "testdata"
- PREFIX
- "/"
- FILES
- ${testdata_resource_files}
- )
-endif()