summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 380ed8e946..3ce9a3aa0a 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -152,11 +152,13 @@ extend_target(Network CONDITION UNIX
${CMAKE_DL_LIBS}
)
-# special case: Do not add this to android!
+# special case begin
+# Do not add this to android!
extend_target(Network CONDITION QT_FEATURE_dnslookup AND UNIX AND NOT INTEGRITY AND NOT ANDROID
SOURCES
kernel/qdnslookup_unix.cpp
)
+# special case end
extend_target(Network CONDITION QT_FEATURE_linux_netlink AND UNIX
SOURCES