summaryrefslogtreecommitdiffstats
path: root/src/plugins/bearer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/bearer/CMakeLists.txt')
-rw-r--r--src/plugins/bearer/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/plugins/bearer/CMakeLists.txt b/src/plugins/bearer/CMakeLists.txt
index c5218959d6..528061d264 100644
--- a/src/plugins/bearer/CMakeLists.txt
+++ b/src/plugins/bearer/CMakeLists.txt
@@ -1,11 +1,14 @@
# Generated from bearer.pro.
-if(NOT ANDROID AND LINUX AND TARGET Qt::DBus) # special case
+# special case begin
+# The whole block is manual.
+if(NOT ANDROID AND LINUX AND TARGET Qt::DBus)
add_subdirectory(generic)
add_subdirectory(connman)
add_subdirectory(networkmanager)
-elseif(ANDROID AND NOT ANDROID_EMBEDDED) # special case
+elseif(ANDROID AND NOT ANDROID_EMBEDDED)
add_subdirectory(android)
-else() # special case
+else()
add_subdirectory(generic)
endif()
+# special case end