summaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2022-05-18 00:26:03 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2022-05-19 07:23:09 +0000
commitefdb022abcf46445f0dabffd1c2f4f690b6d9940 (patch)
treec73d486580d647142a5a1587b817616b27fc9bbe /tests/auto/qmltest/CMakeLists.txt
parentff859341521649948413be187add265a76caf0c4 (diff)
Make sure qml test data is packaged as test resources
This will make sure the test data is packaged and available on device at runtime. Task-number: QTBUG-88846 Pick-to: 6.2 6.3 Change-Id: I9a62299243a784b5e3857ddd968a2abcdd3d6d54 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Sami Varanka <sami.varanka@qt.io> Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io>
Diffstat (limited to 'tests/auto/qmltest/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/qmltest/CMakeLists.txt b/tests/auto/qmltest/CMakeLists.txt
index 8ab433b4..3a53e40f 100644
--- a/tests/auto/qmltest/CMakeLists.txt
+++ b/tests/auto/qmltest/CMakeLists.txt
@@ -1,9 +1,15 @@
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ *)
+list(APPEND test_data ${test_data_glob})
+
qt_internal_add_test(tst_qmltest
QMLTEST
SOURCES
tst_qmltest.cpp
PUBLIC_LIBRARIES
Qt::Gui
+ TESTDATA ${test_data}
)
set(qmltest_resource_files