aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2022-05-09 15:40:41 +0200
committerMarc Mutz <marc.mutz@qt.io>2022-05-09 23:42:21 +0200
commit868a5c19bcd45df27dca365264084c3bbb365701 (patch)
tree8755b28dd34d6bb5db697a8ed926b06efa92cf1c /src/qml/CMakeLists.txt
parentc2b1aad7918d23f3094525c0a57ae4c9fd88b81e (diff)
Add a TU for QQmlDebugServiceFactory to de-inline dtor & includemocs
Destructors of polymorphic classes should be out-of-line. Header moc files should be included into the implementation files. Both need a TU, so add one. Task-number: QTBUG-102948 Task-number: QTBUG-45582 Change-Id: Ifbfb7f462aa94c7f7e2db8a179e06392f021e097 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 0191be67da..1f9658eb14 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -526,7 +526,7 @@ qt_internal_extend_target(Qml CONDITION QT_FEATURE_qml_debug
debugger/qqmldebugserver.cpp debugger/qqmldebugserver_p.h
debugger/qqmldebugserverconnection_p.h
debugger/qqmldebugservice.cpp debugger/qqmldebugservice_p.h
- debugger/qqmldebugservicefactory_p.h
+ debugger/qqmldebugservicefactory.cpp debugger/qqmldebugservicefactory_p.h
debugger/qqmldebugserviceinterfaces.cpp
debugger/qqmlprofiler.cpp
debugger/qqmlprofilerdefinitions_p.h