aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Wheeler <scott@directededge.com>2019-09-10 12:45:36 +0200
committerScott Wheeler <scott@directededge.com>2019-09-10 12:45:36 +0200
commit085180e9a477b590cf5fac3e5821825ddad79eb1 (patch)
tree0b3c71673d3929c6e5e885e650a08d835221bb21 /CMakeLists.txt
parentef1312d62239f399c40233d76ef3328b8dadf984 (diff)
Require at least CMake 3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d2470c6..7bcdf06b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,7 @@
-cmake_minimum_required(VERSION 2.8.0 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.0.0 FATAL_ERROR)
project(taglib)
-if(NOT ${CMAKE_VERSION} VERSION_LESS 2.8.12)
- cmake_policy(SET CMP0022 OLD)
-endif()
-
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
if(DEFINED ENABLE_STATIC)