aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-02-17 17:34:35 +0100
committerDominik Holland <dominik.holland@qt.io>2021-05-10 17:28:11 +0200
commit8e3d637e7776638149119bd62f459178cbca2955 (patch)
tree077f7a597039a05555da2c2fe33c1535227dd35e /tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
parenteac2590d4266e234f0f2ec4d261d940b14dd79bf (diff)
cmake integration of the ivigenerator
Rerun pro2cmake.py for all examples and tests. Ivigenerator based tests and examples are compiling fine, but the cmake files need to be reworked to be also able to run them. Task-number: AUTOSUITE-1633 Change-Id: Icb95ecfa62ecb319d042dc30ea9f643b69a4aacf Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt32
1 files changed, 14 insertions, 18 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
index 4e6a6a7..ada5903 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
@@ -1,23 +1,19 @@
# Generated from qmlplugin.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## qmlplugin Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(qmlplugin
- MODULE
- INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
- PUBLIC_LIBRARIES
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
- Qt::IviCore
- ivivehiclefunctions
+# IVI Generator:
+qt6_ivigenerator(echo_frontend_noprivate_qmlplugin # special case
+ QFACE_SOURCES ../../../org.example.echo.qface
+ QFACE_FORMAT qmlplugin
+ QFACE_ANNOTATIONS ../../../no-private.yaml
)
-#### Keys ignored in scope 1:.:.:qmlplugin.pro:<TRUE>:
-# QFACE_ANNOTATIONS = "../../../no-private.yaml"
-# QFACE_FORMAT = "qmlplugin"
-# QFACE_SOURCES = "../../../org.example.echo.qface"
-# TEMPLATE = "lib"
-
-qt_autogen_tools_initial_setup(qmlplugin)
+target_link_libraries(echo_frontend_noprivate_qmlplugin PRIVATE # special case
+ echo_noprivate_frontend
+ Qt::IviCore
+ Qt::IviVehicleFunctions
+)