aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt32
1 files changed, 14 insertions, 18 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
index 4e6a6a7..ada5903 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/qmlplugin/CMakeLists.txt
@@ -1,23 +1,19 @@
# Generated from qmlplugin.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## qmlplugin Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(qmlplugin
- MODULE
- INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
- PUBLIC_LIBRARIES
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
- Qt::IviCore
- ivivehiclefunctions
+# IVI Generator:
+qt6_ivigenerator(echo_frontend_noprivate_qmlplugin # special case
+ QFACE_SOURCES ../../../org.example.echo.qface
+ QFACE_FORMAT qmlplugin
+ QFACE_ANNOTATIONS ../../../no-private.yaml
)
-#### Keys ignored in scope 1:.:.:qmlplugin.pro:<TRUE>:
-# QFACE_ANNOTATIONS = "../../../no-private.yaml"
-# QFACE_FORMAT = "qmlplugin"
-# QFACE_SOURCES = "../../../org.example.echo.qface"
-# TEMPLATE = "lib"
-
-qt_autogen_tools_initial_setup(qmlplugin)
+target_link_libraries(echo_frontend_noprivate_qmlplugin PRIVATE # special case
+ echo_noprivate_frontend
+ Qt::IviCore
+ Qt::IviVehicleFunctions
+)