aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/qivisimulationengine/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 15:14:38 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-26 12:11:07 +0200
commitf357bb6e64ea24e4ec27b6d84c94c3a6dadc24fa (patch)
treef8fe67b7ea4e609f0f16ddcdbed5c636f9bd5966 /tests/auto/core/qivisimulationengine/CMakeLists.txt
parentc09bcfbdf0232f8b827fc2a4dd19ca433a62df5f (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I7f86da0411b4870b1a9f9e1ed0b63cf30ccd48ad Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'tests/auto/core/qivisimulationengine/CMakeLists.txt')
-rw-r--r--tests/auto/core/qivisimulationengine/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/auto/core/qivisimulationengine/CMakeLists.txt b/tests/auto/core/qivisimulationengine/CMakeLists.txt
index 2f6e20f..70e5f39 100644
--- a/tests/auto/core/qivisimulationengine/CMakeLists.txt
+++ b/tests/auto/core/qivisimulationengine/CMakeLists.txt
@@ -4,7 +4,7 @@
## tst_qivisimulationengine Test:
#####################################################################
-qt_add_test(tst_qivisimulationengine
+qt_internal_add_test(tst_qivisimulationengine
SOURCES
tst_qivisimulationengine.cpp
PUBLIC_LIBRARIES
@@ -21,7 +21,7 @@ set(resource_resource_files
"simple.qml"
)
-qt_add_resource(tst_qivisimulationengine "resource"
+qt_internal_add_resource(tst_qivisimulationengine "resource"
PREFIX
"/"
FILES