summaryrefslogtreecommitdiffstats
path: root/tests/auto/qopcuaclient/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 15:25:46 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 20:16:38 +0200
commit99ad0b5c951e96f42de6d729d7ef4c37cd1554c3 (patch)
tree0b7b506bb727275fc37d2b3fc87b1a2806f7b4b7 /tests/auto/qopcuaclient/CMakeLists.txt
parent723a02b2355a5c91bce10be39279404ca09f6032 (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I58d7107f556e2f06ecf5b47fab65ccec7d929b6d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/qopcuaclient/CMakeLists.txt')
-rw-r--r--tests/auto/qopcuaclient/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/auto/qopcuaclient/CMakeLists.txt b/tests/auto/qopcuaclient/CMakeLists.txt
index a098ffc..a6eaa99 100644
--- a/tests/auto/qopcuaclient/CMakeLists.txt
+++ b/tests/auto/qopcuaclient/CMakeLists.txt
@@ -4,7 +4,7 @@
## tst_qopcuaclient Test:
#####################################################################
-qt_add_test(tst_qopcuaclient
+qt_internal_add_test(tst_qopcuaclient
SOURCES
../../common/backend_environment.h
tst_client.cpp
@@ -20,7 +20,7 @@ set(data_resource_files
"../../open62541-testserver/pki/own/certs/open62541-testserver.der"
)
-qt_add_resource(tst_qopcuaclient "data"
+qt_internal_add_resource(tst_qopcuaclient "data"
PREFIX
"/"
FILES
@@ -31,7 +31,7 @@ qt_add_resource(tst_qopcuaclient "data"
## Scopes:
#####################################################################
-qt_extend_target(tst_qopcuaclient CONDITION QT_FEATURE_open62541_security AND QT_FEATURE_open62541 # special case
+qt_internal_extend_target(tst_qopcuaclient CONDITION QT_FEATURE_open62541_security AND QT_FEATURE_open62541 # special case
DEFINES
SERVER_SUPPORTS_SECURITY
)