aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/default
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2020-08-11 11:57:24 +0200
committerMitch Curtis <mitch.curtis@qt.io>2020-08-26 11:46:11 +0200
commit80c5d0841e6f7c0c9aedfdc01b5d060ab2f66b7d (patch)
tree8de7772b63706db7408debf30c4e3f5ab9425b31 /src/imports/controls/default
parentb47e26d29db05ecf87f74815e37e0bf7394d06ba (diff)
Fix CMake build
Task-number: QTBUG-82922 Change-Id: I75f4a553a6bb260f77bfa791f12fa42e80131e09 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/controls/default')
-rw-r--r--src/imports/controls/default/.prev_CMakeLists.txt308
-rw-r--r--src/imports/controls/default/CMakeLists.txt308
-rw-r--r--src/imports/controls/default/impl/CMakeLists.txt44
3 files changed, 660 insertions, 0 deletions
diff --git a/src/imports/controls/default/.prev_CMakeLists.txt b/src/imports/controls/default/.prev_CMakeLists.txt
new file mode 100644
index 00000000..608f81b6
--- /dev/null
+++ b/src/imports/controls/default/.prev_CMakeLists.txt
@@ -0,0 +1,308 @@
+# Generated from default.pro.
+
+#####################################################################
+## qtquickcontrols2defaultstyleplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquickcontrols2defaultstyleplugin
+ URI "QtQuick.Controls.Default"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuickControls2DefaultStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ GENERATE_QMLTYPES
+ SOURCES
+ qquickdefaultstyle.cpp qquickdefaultstyle_p.h
+ qquickdefaulttheme.cpp qquickdefaulttheme_p.h
+ qtquickcontrols2defaultstyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(qtquickcontrols2defaultstyleplugin_resource_files
+ "images/arrow-indicator.png"
+ "images/arrow-indicator@2x.png"
+ "images/arrow-indicator@3x.png"
+ "images/arrow-indicator@4x.png"
+ "images/check.png"
+ "images/check@2x.png"
+ "images/check@3x.png"
+ "images/check@4x.png"
+ "images/dial-indicator.png"
+ "images/dial-indicator@2x.png"
+ "images/dial-indicator@3x.png"
+ "images/dial-indicator@4x.png"
+ "images/double-arrow.png"
+ "images/double-arrow@2x.png"
+ "images/double-arrow@3x.png"
+ "images/double-arrow@4x.png"
+ "images/drop-indicator.png"
+ "images/drop-indicator@2x.png"
+ "images/drop-indicator@3x.png"
+ "images/drop-indicator@4x.png"
+)
+
+qt_add_resource(qtquickcontrols2defaultstyleplugin "qtquickcontrols2defaultstyleplugin"
+ PREFIX
+ "/qt-project.org/imports/QtQuick/Controls/Default"
+ FILES
+ ${qtquickcontrols2defaultstyleplugin_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:default.pro:<TRUE>:
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Default"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Controls/Default"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"
+
+set(qml_files
+ "AbstractButton.qml"
+ "Action.qml"
+ "ActionGroup.qml"
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "ButtonGroup.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "ComboBox.qml"
+ "Container.qml"
+ "Control.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "HorizontalHeaderView.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuBar.qml"
+ "MenuBarItem.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "Page.qml"
+ "PageIndicator.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "ScrollView.qml"
+ "Slider.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "StackView.qml"
+ "SwipeDelegate.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
+ "SwipeView.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "TextArea.qml"
+ "TextField.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+ "VerticalHeaderView.qml"
+)
+set_source_files_properties(AbstractButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Action.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(ActionGroup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(ApplicationWindow.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(BusyIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Button.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ButtonGroup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ComboBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Container.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Control.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(DelayButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Dial.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Dialog.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(DialogButtonBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Drawer.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Frame.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(GroupBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+set_source_files_properties(ItemDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Label.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Menu.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuBarItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Page.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(PageIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Pane.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Popup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RangeSlider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RoundButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ScrollBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Slider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SpinBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SplitView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.13;6.0"
+)
+set_source_files_properties(StackView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwipeDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Switch.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwitchDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwipeView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextArea.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextField.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ToolTip.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Tumbler.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(VerticalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+
+qt6_target_qml_files(qtquickcontrols2defaultstyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/default/CMakeLists.txt b/src/imports/controls/default/CMakeLists.txt
new file mode 100644
index 00000000..336d04c9
--- /dev/null
+++ b/src/imports/controls/default/CMakeLists.txt
@@ -0,0 +1,308 @@
+# Generated from default.pro.
+
+#####################################################################
+## qtquickcontrols2defaultstyleplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquickcontrols2defaultstyleplugin
+ URI "QtQuick.Controls.Default"
+ VERSION "6.0" # special case
+ CLASSNAME QtQuickControls2DefaultStylePlugin
+ DEPENDENCIES
+ QtQuick.Controls/2.5
+ GENERATE_QMLTYPES
+ SOURCES
+ qquickdefaultstyle.cpp qquickdefaultstyle_p.h
+ qquickdefaulttheme.cpp qquickdefaulttheme_p.h
+ qtquickcontrols2defaultstyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(qtquickcontrols2defaultstyleplugin_resource_files
+ "images/arrow-indicator.png"
+ "images/arrow-indicator@2x.png"
+ "images/arrow-indicator@3x.png"
+ "images/arrow-indicator@4x.png"
+ "images/check.png"
+ "images/check@2x.png"
+ "images/check@3x.png"
+ "images/check@4x.png"
+ "images/dial-indicator.png"
+ "images/dial-indicator@2x.png"
+ "images/dial-indicator@3x.png"
+ "images/dial-indicator@4x.png"
+ "images/double-arrow.png"
+ "images/double-arrow@2x.png"
+ "images/double-arrow@3x.png"
+ "images/double-arrow@4x.png"
+ "images/drop-indicator.png"
+ "images/drop-indicator@2x.png"
+ "images/drop-indicator@3x.png"
+ "images/drop-indicator@4x.png"
+)
+
+qt_add_resource(qtquickcontrols2defaultstyleplugin "qtquickcontrols2defaultstyleplugin"
+ PREFIX
+ "/qt-project.org/imports/QtQuick/Controls/Default"
+ FILES
+ ${qtquickcontrols2defaultstyleplugin_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:default.pro:<TRUE>:
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Default"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Controls/Default"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"
+
+set(qml_files
+ "AbstractButton.qml"
+ "Action.qml"
+ "ActionGroup.qml"
+ "ApplicationWindow.qml"
+ "BusyIndicator.qml"
+ "Button.qml"
+ "ButtonGroup.qml"
+ "CheckBox.qml"
+ "CheckDelegate.qml"
+ "ComboBox.qml"
+ "Container.qml"
+ "Control.qml"
+ "DelayButton.qml"
+ "Dial.qml"
+ "Dialog.qml"
+ "DialogButtonBox.qml"
+ "Drawer.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "HorizontalHeaderView.qml"
+ "ItemDelegate.qml"
+ "Label.qml"
+ "Menu.qml"
+ "MenuBar.qml"
+ "MenuBarItem.qml"
+ "MenuItem.qml"
+ "MenuSeparator.qml"
+ "Page.qml"
+ "PageIndicator.qml"
+ "Pane.qml"
+ "Popup.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "RadioDelegate.qml"
+ "RangeSlider.qml"
+ "RoundButton.qml"
+ "ScrollBar.qml"
+ "ScrollIndicator.qml"
+ "ScrollView.qml"
+ "Slider.qml"
+ "SpinBox.qml"
+ "SplitView.qml"
+ "StackView.qml"
+ "SwipeDelegate.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
+ "SwipeView.qml"
+ "TabBar.qml"
+ "TabButton.qml"
+ "TextArea.qml"
+ "TextField.qml"
+ "ToolBar.qml"
+ "ToolButton.qml"
+ "ToolSeparator.qml"
+ "ToolTip.qml"
+ "Tumbler.qml"
+ "VerticalHeaderView.qml"
+)
+set_source_files_properties(AbstractButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Action.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(ActionGroup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(ApplicationWindow.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(BusyIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Button.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ButtonGroup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ComboBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Container.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Control.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(DelayButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Dial.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Dialog.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(DialogButtonBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Drawer.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Frame.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(GroupBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+set_source_files_properties(ItemDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Label.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Menu.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuBarItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Page.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(PageIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Pane.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Popup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RangeSlider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RoundButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ScrollBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Slider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SpinBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SplitView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.13;6.0"
+)
+set_source_files_properties(StackView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwipeDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Switch.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwitchDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwipeView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextArea.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextField.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ToolTip.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Tumbler.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(VerticalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+
+qt6_target_qml_files(qtquickcontrols2defaultstyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/default/impl/CMakeLists.txt b/src/imports/controls/default/impl/CMakeLists.txt
new file mode 100644
index 00000000..d90ef86b
--- /dev/null
+++ b/src/imports/controls/default/impl/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from default-impl.pro.
+
+#####################################################################
+## qtquickcontrols2defaultstyleimplplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquickcontrols2defaultstyleimplplugin
+ URI "QtQuick.Controls.Default.impl"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuickControls2DefaultStyleImplPlugin
+ DEPENDENCIES
+ QtQuick.Templates/6.0
+ QtQuick.Controls/6.0
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ qquickdefaultbusyindicator.cpp qquickdefaultbusyindicator_p.h
+ qquickdefaultdial.cpp qquickdefaultdial_p.h
+ qquickdefaultprogressbar.cpp qquickdefaultprogressbar_p.h
+ qtquickcontrols2defaultstyleimplplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::QmlPrivate
+ Qt::QuickControls2ImplPrivate
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:default-impl.pro:<TRUE>:
+# OTHER_FILES = "qmldir"
+# QML_IMPORT_NAME = "QtQuick.Controls.Default.impl"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# QT_FOR_CONFIG = "quickcontrols2-private"
+# TARGETPATH = "QtQuick/Controls/Default/impl"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"