aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/windows
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/controls/windows')
-rw-r--r--src/imports/controls/windows/.prev_CMakeLists.txt92
-rw-r--r--src/imports/controls/windows/CMakeLists.txt4
-rw-r--r--src/imports/controls/windows/qtquickcontrols2windowsstyleplugin.cpp5
3 files changed, 98 insertions, 3 deletions
diff --git a/src/imports/controls/windows/.prev_CMakeLists.txt b/src/imports/controls/windows/.prev_CMakeLists.txt
new file mode 100644
index 00000000..d68839b2
--- /dev/null
+++ b/src/imports/controls/windows/.prev_CMakeLists.txt
@@ -0,0 +1,92 @@
+# Generated from windows.pro.
+
+#####################################################################
+## qtquickcontrols2windowsstyleplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquickcontrols2windowsstyleplugin
+ URI "QtQuick.Controls.Windows"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuickControls2WindowsStylePlugin
+ IMPORTS
+ QtQuick.Controls.Fusion/auto
+ GENERATE_QMLTYPES
+ SOURCES
+ qtquickcontrols2windowsstyleplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickControls2
+ Qt::QuickTemplates2
+)
+
+#### Keys ignored in scope 1:.:.:windows.pro:<TRUE>:
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Windows"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Controls/Windows"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-windows)"
+
+set(qml_files
+ "Button.qml"
+ "CheckBox.qml"
+ "ComboBox.qml"
+ "Frame.qml"
+ "GroupBox.qml"
+ "ProgressBar.qml"
+ "RadioButton.qml"
+ "Slider.qml"
+ "SpinBox.qml"
+ "TextArea.qml"
+ "TextField.qml"
+)
+set_source_files_properties(Button.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(CheckBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(ComboBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(Frame.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(GroupBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(RadioButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(Slider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(SpinBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(TextArea.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+set_source_files_properties(TextField.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
+
+qt6_target_qml_files(qtquickcontrols2windowsstyleplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/controls/windows/CMakeLists.txt b/src/imports/controls/windows/CMakeLists.txt
index 749d19a2..6bcbc26c 100644
--- a/src/imports/controls/windows/CMakeLists.txt
+++ b/src/imports/controls/windows/CMakeLists.txt
@@ -45,6 +45,7 @@ set(qml_files
"ComboBox.qml"
"Frame.qml"
"GroupBox.qml"
+ "ProgressBar.qml"
"RadioButton.qml"
"Slider.qml"
"SpinBox.qml"
@@ -66,6 +67,9 @@ set_source_files_properties(Frame.qml PROPERTIES
set_source_files_properties(GroupBox.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "6.0"
+)
set_source_files_properties(RadioButton.qml PROPERTIES
QT_QML_SOURCE_VERSION "6.0"
)
diff --git a/src/imports/controls/windows/qtquickcontrols2windowsstyleplugin.cpp b/src/imports/controls/windows/qtquickcontrols2windowsstyleplugin.cpp
index 9c50f4fb..1136cd9a 100644
--- a/src/imports/controls/windows/qtquickcontrols2windowsstyleplugin.cpp
+++ b/src/imports/controls/windows/qtquickcontrols2windowsstyleplugin.cpp
@@ -46,8 +46,8 @@ class QtQuickControls2WindowsStylePlugin : public QQuickStylePlugin
Q_PLUGIN_METADATA(IID QQmlExtensionInterface_iid)
public:
- void registerTypes(const char *uri) override;
QString name() const override;
+ void initializeTheme(QQuickTheme *theme) override;
};
QString QtQuickControls2WindowsStylePlugin::name() const
@@ -55,9 +55,8 @@ QString QtQuickControls2WindowsStylePlugin::name() const
return QStringLiteral("Windows");
}
-void QtQuickControls2WindowsStylePlugin::registerTypes(const char *uri)
+void QtQuickControls2WindowsStylePlugin::initializeTheme(QQuickTheme */*theme*/)
{
- QQuickStylePlugin::registerTypes(uri);
}
QT_END_NAMESPACE