summaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-01-18 20:35:47 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-01-18 20:35:47 +0100
commit908e924b9eee862aa9e1cf1515562fc9104117d6 (patch)
tree37fc54700a0eeb2968910dfd163b649cf1250772 /src/imports
parentc89265b5d9fac719a88c2fafa5cc445bd3e701ba (diff)
parent804fb1f97a713edc96435433d15b09a3cb670416 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/CMakeLists.txt3
-rw-r--r--src/imports/scxmlstatemachine/.prev_CMakeLists.txt30
-rw-r--r--src/imports/scxmlstatemachine/CMakeLists.txt30
3 files changed, 63 insertions, 0 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
new file mode 100644
index 0000000..805a479
--- /dev/null
+++ b/src/imports/CMakeLists.txt
@@ -0,0 +1,3 @@
+# Generated from imports.pro.
+
+add_subdirectory(scxmlstatemachine)
diff --git a/src/imports/scxmlstatemachine/.prev_CMakeLists.txt b/src/imports/scxmlstatemachine/.prev_CMakeLists.txt
new file mode 100644
index 0000000..40bb2aa
--- /dev/null
+++ b/src/imports/scxmlstatemachine/.prev_CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from scxmlstatemachine.pro.
+
+#####################################################################
+## scxml Plugin:
+#####################################################################
+
+qt_add_qml_module(scxml
+ URI "QtScxml"
+ VERSION "5.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QScxmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ eventconnection.cpp eventconnection_p.h
+ invokedservices.cpp invokedservices_p.h
+ plugin.cpp
+ statemachineextended.cpp statemachineextended_p.h
+ statemachineloader.cpp statemachineloader_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::Scxml
+)
+
+#### Keys ignored in scope 1:.:.:scxmlstatemachine.pro:<TRUE>:
+# IMPORT_VERSION = "5.$$QT_MINOR_VERSION"
+# OTHER_FILES = "plugins.qmltypes" "qmldir"
+# TARGETPATH = "QtScxml"
diff --git a/src/imports/scxmlstatemachine/CMakeLists.txt b/src/imports/scxmlstatemachine/CMakeLists.txt
new file mode 100644
index 0000000..f0218cd
--- /dev/null
+++ b/src/imports/scxmlstatemachine/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from scxmlstatemachine.pro.
+
+#####################################################################
+## scxml Plugin:
+#####################################################################
+
+qt_add_qml_module(declarative_scxml # special case
+ URI "QtScxml"
+ VERSION "5.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QScxmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ eventconnection.cpp eventconnection_p.h
+ invokedservices.cpp invokedservices_p.h
+ plugin.cpp
+ statemachineextended.cpp statemachineextended_p.h
+ statemachineloader.cpp statemachineloader_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::Scxml
+)
+
+#### Keys ignored in scope 1:.:.:scxmlstatemachine.pro:<TRUE>:
+# IMPORT_VERSION = "5.$$QT_MINOR_VERSION"
+# OTHER_FILES = "plugins.qmltypes" "qmldir"
+# TARGETPATH = "QtScxml"